Outage with upstream auth provider Clerk

Incident Report for Draftbit

Resolved

This incident has been resolved.
Posted May 27, 2026 - 18:40 CDT

Identified

We're having an issue with our authentication provider, Clerk, causing issues loading the dashboard and other authenticated services.
Posted May 26, 2026 - 16:48 CDT
This incident affected: Core (Draftbit API / Backend, Draftbit Dashboard & Portal).